Subject : Apps won’t load, but browser works fine (WebOS)
Symptom
■ TV is connected to the internet but app won’t load
■ TV browser is working but app won’t load
■ Network is disconnected when accessing app but wifi is connected to the network
Cause
■ A DNS server converts the web address name (www.google.com), into a web address ip (74.125.224.72). Like any other server, sometimes DNS servers go down, and devices get confused.
How to fix
Your best bet to resolve this issue is to set your DNS locations manually. Luckily, Google hosts public DNS servers for anyone to use.
Google's public DNS servers are 8.8.8.8 and 8.8.4.4.
How to set your DNS manually
■ Press the Home/Smart button on your remote to bring up your launcher bar.
■ Click the Settings icon in the top-right.
■ Choose the All Settings option at the bottom
■ Choose the Network menu from the left then Choose Wi-Fi Connection.
■ Choose Advanced Wi-Fi Settings at the bottom
Note: In this menu, your network should have a checkmark
■ Click the Edit button.
■ Uncheck the box labeled Set Automatically.
■ Click in the box labelled DNS Server and enter 8.8.8.8 or 8.8.4.4
■ Then click Connect.
■ Press the Home/Smart button on your remote and try to launch the App.